summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Reichl <preichl@redhat.com>2015-08-04 09:25:08 -0400
committerJakub Hrozek <jhrozek@redhat.com>2015-08-17 15:10:14 +0200
commite2e334b2f51118cb14c7391c4e4e44ff247ef638 (patch)
treed8d8ff0540185feb43ffe94bdad2b62c405e702b /Makefile.am
parent9da121c08b785b56733a11fa46e14c708dda62e9 (diff)
downloadsssd-e2e334b2f51118cb14c7391c4e4e44ff247ef638.tar.gz
sssd-e2e334b2f51118cb14c7391c4e4e44ff247ef638.tar.xz
sssd-e2e334b2f51118cb14c7391c4e4e44ff247ef638.zip
LDAP: sanitize group name when used in filter
cleanup_groups() uses DN of group in filter for ldbsearch. But the name might contain characters with special meaning for filtering like - "*()\/" Resolves: https://fedorahosted.org/sssd/ticket/2744 Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7dc4875c9..9cc5f3845 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -219,6 +219,7 @@ if HAVE_CMOCKA
sss_sifp-tests \
test_search_bases \
test_ldap_auth \
+ test_ldap_id_cleanup \
test_sdap_access \
sdap-tests \
test_sysdb_views \
@@ -2145,6 +2146,27 @@ test_ldap_auth_LDADD = \
libsss_test_common.la \
$(NULL)
+test_ldap_id_cleanup_SOURCES = \
+ $(sssd_be_SOURCES) \
+ src/tests/cmocka/test_ldap_id_cleanup.c \
+ src/providers/ldap/ldap_id_cleanup.c \
+ $(NULL)
+test_ldap_id_cleanup_CFLAGS = \
+ $(AM_CFLAGS) \
+ -DUNIT_TESTING
+ $(NULL)
+test_ldap_id_cleanup_LDADD = \
+ $(PAM_LIBS) \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(SSSD_LIBS) \
+ $(CARES_LIBS) \
+ $(KRB5_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_ldap_common.la \
+ libsss_test_common.la \
+ $(NULL)
+
test_sdap_access_SOURCES = \
$(sssd_be_SOURCES) \
src/tests/cmocka/test_sdap_access.c \