summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-07-24 13:13:08 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-08-14 23:44:18 +0200
commitdb5f9ab3feb85aa444eab20428ca2b98801b6783 (patch)
tree2637e5a466397ef95c9846cedc2c7c158b4bf93d /Makefile.am
parentd95bcfe23c574de7b6b7b44b52a0d4db5cc8529a (diff)
downloadsssd-db5f9ab3feb85aa444eab20428ca2b98801b6783.tar.gz
sssd-db5f9ab3feb85aa444eab20428ca2b98801b6783.tar.xz
sssd-db5f9ab3feb85aa444eab20428ca2b98801b6783.zip
IPA: Always re-fetch the keytab from the IPA server
Even if a keytab for one-way trust exists, re-fetch the keytab again and try to use it. Fall back to the previous one if it exists. This is in order to allow the admin to re-establish the trust keytabs with a simple sssd restart. Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b64317d6..ed107fd5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2550,6 +2550,8 @@ test_ipa_subdom_server_LDFLAGS = \
-Wl,-wrap,krb5_kt_default \
-Wl,-wrap,execle \
-Wl,-wrap,execve \
+ -Wl,-wrap,rename \
+ -Wl,-wrap,sss_unique_filename \
$(NULL)
test_ipa_subdom_server_LDADD = \
$(PAM_LIBS) \