summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Březina <pbrezina@redhat.com>2014-12-16 15:19:05 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-01-23 21:45:38 +0100
commit3a8f6b575f4019f21c9425a26f1b346c08a197ae (patch)
treee640b5e6302b48b38ef3a3172f1e58a3500a74ff /Makefile.am
parent51d65c4ad15c2cc23f38fa09dd6efeb15e4f3e86 (diff)
downloadsssd-3a8f6b575f4019f21c9425a26f1b346c08a197ae.tar.gz
sssd-3a8f6b575f4019f21c9425a26f1b346c08a197ae.tar.xz
sssd-3a8f6b575f4019f21c9425a26f1b346c08a197ae.zip
sbus: move common opath functions from ifp to sbus code
These functions are quite general thus they may be part of sbus interface. Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 660b3d40a..ff17b41c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -219,6 +219,7 @@ if HAVE_CMOCKA
test_copy_keytab \
test_child_common \
responder_cache_req-tests \
+ test_sbus_opath \
$(NULL)
if BUILD_IFP
@@ -2208,6 +2209,18 @@ responder_cache_req_tests_LDADD = \
libsss_test_common.la \
$(NULL)
+test_sbus_opath_SOURCES = \
+ src/tests/cmocka/test_sbus_opath.c \
+ $(NULL)
+test_sbus_opath_CFLAGS = \
+ $(AM_CFLAGS)
+test_sbus_opath_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_debug.la \
+ libsss_test_common.la
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client