summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-06-30 19:40:46 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-07-06 15:23:44 +0200
commit01ec08efd0e166ac6f390f8627c6d08dcc63ccc4 (patch)
tree5a95a8a7b36db9baaf18fad0ca0c22eb7a2cc32d /Makefile.am
parenteca74a9559ce1b0f123c14906ad8394fc303f468 (diff)
downloadsssd-01ec08efd0e166ac6f390f8627c6d08dcc63ccc4.tar.gz
sssd-01ec08efd0e166ac6f390f8627c6d08dcc63ccc4.tar.xz
sssd-01ec08efd0e166ac6f390f8627c6d08dcc63ccc4.zip
KRB5: Add and use krb5_auth_queue_send to queue requests by default
Resolves: https://fedorahosted.org/sssd/ticket/2701 Previously, only the krb5 provides used to queue requests, which resulted in concurrent authentication requests stepping on one another. This patch queues requests by default. Reviewed-by: Sumit Bose <sbose@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b427b17f..b8cbc6df2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -230,6 +230,7 @@ if HAVE_CMOCKA
pam-srv-tests \
test_ipa_subdom_util \
test_ipa_subdom_server \
+ test_krb5_wait_queue \
test_cert_utils \
$(NULL)
@@ -2515,6 +2516,22 @@ test_ipa_subdom_server_LDADD = \
libsss_test_common.la \
$(NULL)
+test_krb5_wait_queue_SOURCES = \
+ src/tests/cmocka/common_mock_be.c \
+ src/tests/cmocka/test_krb5_wait_queue.c \
+ src/providers/krb5/krb5_wait_queue.c \
+ $(NULL)
+test_krb5_wait_queue_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_krb5_wait_queue_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(DHASH_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
test_cert_utils_SOURCES = \
src/tests/cmocka/test_cert_utils.c \
$(NULL)