summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Březina <pbrezina@redhat.com>2014-12-17 13:26:16 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-02-17 15:53:39 +0100
commitdf4e1db5d41c903ae57fd880acc76a0ad84aa7b2 (patch)
treefa052523b587c0728638b513582694e61134f409 /Makefile.am
parente8058322725ba050014777ee2484f7e833ab1e3a (diff)
downloadsssd-df4e1db5d41c903ae57fd880acc76a0ad84aa7b2.tar.gz
sssd-df4e1db5d41c903ae57fd880acc76a0ad84aa7b2.tar.xz
sssd-df4e1db5d41c903ae57fd880acc76a0ad84aa7b2.zip
sbus: use hard coded getters instead of generated
Properties are single value of a small number of predefined D-Bus types. There is no need to generate them with codegen. Actually, the source generator for property getters is already quite mess with branching for array, strings and object paths. Adding any more complex type in the future (such as dictionary) would require even more branching or creating a separate path for it. Hard coding the getters will simplify creating new ones for more complex types. This patch also reduces lots of code duplication and creates a simple function for GetAll. Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index caeebce35..fece4b41a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -525,6 +525,7 @@ dist_noinst_HEADERS = \
src/sbus/sssd_dbus.h \
src/sbus/sssd_dbus_meta.h \
src/sbus/sssd_dbus_private.h \
+ src/sbus/sssd_dbus_invokers.h \
src/db/sysdb.h \
src/db/sysdb_sudo.h \
src/db/sysdb_autofs.h \
@@ -710,6 +711,7 @@ libsss_util_la_SOURCES = \
src/sbus/sssd_dbus_meta.c \
src/sbus/sssd_dbus_interface.c \
src/sbus/sssd_dbus_introspect.c \
+ src/sbus/sssd_dbus_invokers.c \
src/sbus/sssd_dbus_properties.c \
src/sbus/sssd_dbus_request.c \
src/sbus/sssd_dbus_server.c \