summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-12-12 17:10:40 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-03-03 16:15:37 +0100
commit8df69bbc58c2f4d3f0b34be9756d9ddf24b1db6d (patch)
tree643138d18dd31a9ea0e5691daf19baea0dc0e396 /Makefile.am
parenteafbc66c2ff6365478e62a8df3fd005bf80e5c7b (diff)
downloadsssd-8df69bbc58c2f4d3f0b34be9756d9ddf24b1db6d.tar.gz
sssd-8df69bbc58c2f4d3f0b34be9756d9ddf24b1db6d.tar.xz
sssd-8df69bbc58c2f4d3f0b34be9756d9ddf24b1db6d.zip
FO: Use SRV TTL in fail over code
Resolves: https://fedorahosted.org/sssd/ticket/1884 Removes the hardcoded SRV TTL timeout and uses TTL from the DNS instead. Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 434f28f52..ffbdf970a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -220,6 +220,7 @@ if HAVE_CMOCKA
test_child_common \
responder_cache_req-tests \
test_sbus_opath \
+ test_fo_srv \
$(NULL)
if HAVE_LIBRESOLV
@@ -2258,6 +2259,24 @@ test_resolv_fake_LDADD = \
$(NULL)
endif # HAVE_LIBRESOLV
+test_fo_srv_SOURCES = \
+ src/tests/cmocka/test_fo_srv.c \
+ src/providers/fail_over.c \
+ src/providers/fail_over_srv.c \
+ $(NULL)
+test_fo_srv_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_fo_srv_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(CARES_LIBS) \
+ $(DHASH_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client