summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-01-13 21:44:21 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-01-15 10:32:54 +0100
commit44703b84feaafa4f0a4f8df11c5a503dcf48616e (patch)
treeb88986fbedf4e2f1cf273c0917e84c3a5c2f376d /Makefile.am
parentdc7d8ab0f796239338ea67cf6698e0bc6b619174 (diff)
downloadsssd-44703b84feaafa4f0a4f8df11c5a503dcf48616e.tar.gz
sssd-44703b84feaafa4f0a4f8df11c5a503dcf48616e.tar.xz
sssd-44703b84feaafa4f0a4f8df11c5a503dcf48616e.zip
TESTS: Cover child_common.c with unit tests
The module wasn't tested properly, which made it harder to patch it Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 355f8c3d5..c14a50fc3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2175,6 +2175,9 @@ test_child_common_CFLAGS = \
$(AM_CFLAGS) \
-DCHILD_DIR=\"$(builddir)\" \
$(NULL)
+test_child_common_LDFLAGS = \
+ -Wl,-wrap,child_io_destructor \
+ $(NULL)
test_child_common_LDADD = \
$(CMOCKA_LIBS) \
$(POPT_LIBS) \