summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-04-09 22:18:35 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-04-14 19:58:30 +0200
commit1e0fa55fb377db788e065de917ba8e149eb56161 (patch)
tree23135820ad4753a5588655d37d1a0fefbc3e6066 /Makefile.am
parent748b38a7991d78cbf4726f2a14ace5e926629a54 (diff)
downloadsssd-1e0fa55fb377db788e065de917ba8e149eb56161.tar.gz
sssd-1e0fa55fb377db788e065de917ba8e149eb56161.tar.xz
sssd-1e0fa55fb377db788e065de917ba8e149eb56161.zip
selinux: Only call semanage if the context actually changes
https://fedorahosted.org/sssd/ticket/2624 Add a function to query the libsemanage database for a user context and only update the database if the context differes from the one set on the server. Adds talloc dependency to libsss_semanage. Reviewed-by: Michal Židek <mzidek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d9724093d..52fbd510d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -789,10 +789,15 @@ endif
libsss_util_la_LDFLAGS = -avoid-version
pkglib_LTLIBRARIES += libsss_semanage.la
+libsss_semanage_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(TALLOC_CFLAGS) \
+ $(NULL)
libsss_semanage_la_SOURCES = \
src/util/sss_semanage.c \
$(NULL)
libsss_semanage_la_LIBADD = \
+ $(TALLOC_LIBS) \
libsss_debug.la \
$(NULL)
if BUILD_SEMANAGE