summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2015-02-23 22:56:55 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-02-25 08:38:42 +0100
commit18372712592b30638772afb5b7e15bfca92c2058 (patch)
tree40d1017c5dcd32b22aa5be03a6424f5a394678b3 /Makefile.am
parent4a5a18f489f4d19aa0571528a7f0c7a8d35ac83f (diff)
downloadsssd-18372712592b30638772afb5b7e15bfca92c2058.tar.gz
sssd-18372712592b30638772afb5b7e15bfca92c2058.tar.xz
sssd-18372712592b30638772afb5b7e15bfca92c2058.zip
TESTS: Run python tests with all supported python versions
This patch add simple bash wrappers for python tests. They are executed either with python2 or python3. Reviewed-by: Stephen Gallagher <sgallagh@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 18 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index f560f7af4..ee23a4111 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -250,13 +250,20 @@ endif # HAVE_CMOCKA
PYTHON_TESTS =
-if BUILD_PYTHON_BINDINGS
-PYTHON_TESTS += src/config/SSSDConfigTest.py \
- src/tests/pyhbac-test.py \
- src/tests/pysss_murmur-test.py
+if BUILD_PYTHON2_BINDINGS
+PYTHON_TESTS += src/config/SSSDConfigTest.py2.sh \
+ src/tests/pyhbac-test.py2.sh \
+ src/tests/pysss_murmur-test.py2.sh \
+ $(NULL)
+endif
+if BUILD_PYTHON3_BINDINGS
+PYTHON_TESTS += src/config/SSSDConfigTest.py3.sh \
+ src/tests/pyhbac-test.py3.sh \
+ src/tests/pysss_murmur-test.py3.sh \
+ $(NULL)
endif
-TEST_EXTENSIONS = .py
+TEST_EXTENSIONS = .sh
TESTS = \
$(PYTHON_TESTS) \
$(non_interactive_cmocka_based_tests) \
@@ -325,6 +332,8 @@ dist_noinst_SCRIPTS = \
src/config/SSSDConfig/ipachangeconf.py \
src/config/SSSDConfig/__init__.py \
src/config/SSSDConfigTest.py \
+ src/config/SSSDConfigTest.py2.sh \
+ src/config/SSSDConfigTest.py3.sh \
src/config/SSSDConfig/sssd_upgrade_config.py \
contrib/rhel/update_debug_levels.py \
contrib/fedora/bashrc_sssd \
@@ -335,7 +344,11 @@ dist_noinst_SCRIPTS = \
contrib/ci/run \
contrib/ci/valgrind-condense \
src/tests/pyhbac-test.py \
+ src/tests/pyhbac-test.py2.sh \
+ src/tests/pyhbac-test.py3.sh \
src/tests/pysss_murmur-test.py \
+ src/tests/pysss_murmur-test.py2.sh \
+ src/tests/pysss_murmur-test.py3.sh \
src/tests/python-test.py \
$(NULL)