summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-10-18 20:52:43 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-10-30 16:36:50 +0100
commitaf8a05f6aea6acd39c4c921ac0fe648940ccafd4 (patch)
treef5231527bf25106a823d94737a609e595a0790f6 /Makefile.am
parent54ddaca98815177a5185e929c3ffe007c977be35 (diff)
downloadsssd-af8a05f6aea6acd39c4c921ac0fe648940ccafd4.tar.gz
sssd-af8a05f6aea6acd39c4c921ac0fe648940ccafd4.tar.xz
sssd-af8a05f6aea6acd39c4c921ac0fe648940ccafd4.zip
KRB5: Move ccache-related functions to krb5_ccache.c
Add a new module krb5_ccache.c that contains all ccache-related operations. The only user of this module shall be krb5_child.c as the other modules will run unprivileged and accessing the keytab requires either privileges of root or the ccache owner.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d90d3312..562d425d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -566,6 +566,7 @@ dist_noinst_HEADERS = \
src/providers/krb5/krb5_utils.h \
src/providers/krb5/krb5_init_shared.h \
src/providers/krb5/krb5_opts.h \
+ src/providers/krb5/krb5_ccache.h \
src/providers/ldap/ldap_common.h \
src/providers/ldap/sdap.h \
src/providers/ldap/sdap_access.h \
@@ -1320,6 +1321,7 @@ strtonum_tests_LDADD = \
krb5_utils_tests_SOURCES = \
src/tests/krb5_utils-tests.c \
src/providers/krb5/krb5_utils.c \
+ src/providers/krb5/krb5_ccache.c \
src/providers/krb5/krb5_common.c \
src/util/sss_krb5.c \
src/providers/data_provider_fo.c \
@@ -1601,6 +1603,7 @@ stress_tests_LDADD = \
krb5_child_test_SOURCES = \
src/tests/krb5_child-test.c \
src/providers/krb5/krb5_utils.c \
+ src/providers/krb5/krb5_ccache.c \
src/providers/krb5/krb5_child_handler.c \
src/providers/krb5/krb5_common.c \
src/util/sss_krb5.c \
@@ -2287,6 +2290,7 @@ libsss_krb5_common_la_SOURCES = \
src/providers/krb5/krb5_access.c \
src/providers/krb5/krb5_child_handler.c \
src/providers/krb5/krb5_init_shared.c \
+ src/providers/krb5/krb5_ccache.c \
src/util/sss_krb5.c \
src/util/become_user.c \
$(NULL)