summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-07-24 13:13:08 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-09-07 18:22:05 +0200
commit042600d08a9d3188d7d3135fc235e6a7c2237a4b (patch)
treebc7bac8294c7493119544cdb8ef0c1b62374b79f /Makefile.am
parent5b71bd7da12503792a481b1599bfcf9415b1014f (diff)
downloadsssd-042600d08a9d3188d7d3135fc235e6a7c2237a4b.tar.gz
sssd-042600d08a9d3188d7d3135fc235e6a7c2237a4b.tar.xz
sssd-042600d08a9d3188d7d3135fc235e6a7c2237a4b.zip
IPA: Always re-fetch the keytab from the IPA serverf23
Even if a keytab for one-way trust exists, re-fetch the keytab again and try to use it. Fall back to the previous one if it exists. This is in order to allow the admin to re-establish the trust keytabs with a simple sssd restart. Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b8cbc6df2..4e58b4f41 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2501,6 +2501,8 @@ test_ipa_subdom_server_LDFLAGS = \
-Wl,-wrap,krb5_kt_default \
-Wl,-wrap,execle \
-Wl,-wrap,execve \
+ -Wl,-wrap,rename \
+ -Wl,-wrap,sss_unique_filename \
$(NULL)
test_ipa_subdom_server_LDADD = \
$(PAM_LIBS) \