summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-09-04 09:27:17 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-09-21 17:04:00 +0200
commit99c5f2f6ba0af6ce52be0d82ec2794bacc215742 (patch)
treea538978333a21269e985033b853589919fd6ae41 /Makefile.am
parentb5825c74b6bf7a99ae2172392dbecb51179013a6 (diff)
downloadsssd-99c5f2f6ba0af6ce52be0d82ec2794bacc215742.tar.gz
sssd-99c5f2f6ba0af6ce52be0d82ec2794bacc215742.tar.xz
sssd-99c5f2f6ba0af6ce52be0d82ec2794bacc215742.zip
DP: Provide a way to mark subdomain as disabled and auto-enable it later with offline_timeout
https://fedorahosted.org/sssd/ticket/2637 Adds a new Data Provider function be_mark_dom_offline() that is a replacement for be_mark_offline(). When called, the function would either set the whole back end offline, just like be_mark_offline or just set the subdomain status to inactive. When a subdomain is inactive, there is a singleton timed task that would re-set the subdomin after offline_timeout seconds. Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 08799c729..44c78232e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -237,6 +237,7 @@ if HAVE_CMOCKA
test_krb5_wait_queue \
test_cert_utils \
test_ldap_id_cleanup \
+ test_data_provider_be \
$(NULL)
if HAVE_LIBRESOLV
@@ -2573,6 +2574,31 @@ test_cert_utils_LDADD = \
libsss_cert.la \
libsss_crypt.la \
$(NULL)
+
+test_data_provider_be_SOURCES = \
+ $(sssd_be_SOURCES) \
+ src/tests/cmocka/test_data_provider_be.c \
+ src/tests/cmocka/common_mock_be.c \
+ $(NULL)
+test_data_provider_be_CFLAGS = \
+ $(AM_CFLAGS) \
+ -DUNIT_TESTING \
+ $(CRYPTO_CFLAGS) \
+ $(NULL)
+test_data_provider_be_LDFLAGS = \
+ -Wl,-wrap,_tevent_add_timer \
+ $(NULL)
+test_data_provider_be_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(CARES_LIBS) \
+ $(POPT_LIBS) \
+ $(PAM_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_debug.la \
+ libsss_test_common.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client