summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-05-26 12:40:33 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-06-14 21:44:39 +0200
commit89ddc9ed474e9ac2b1e7bccb0a58610babf26cf8 (patch)
tree780876e8d274177f2ac16ba2adfa3f6f4db2c0c0 /Makefile.am
parent27e89b6925334565c73c407a9ae2809358789c81 (diff)
downloadsssd-89ddc9ed474e9ac2b1e7bccb0a58610babf26cf8.tar.gz
sssd-89ddc9ed474e9ac2b1e7bccb0a58610babf26cf8.tar.xz
sssd-89ddc9ed474e9ac2b1e7bccb0a58610babf26cf8.zip
IPA: Split two functions to new module ipa_subdomains_utils.c
These functions will be later reused by the subdomains_server.c module. Splitting them into a separate subdomains_utils.c module will make sure there are no cyclic dependencies and the functions are testable in isolation. Reviewed-by: Sumit Bose <sbose@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b85290896..816f18e4c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -226,6 +226,7 @@ if HAVE_CMOCKA
test_sbus_opath \
test_fo_srv \
pam-srv-tests \
+ test_ipa_subdom_util \
$(NULL)
if HAVE_LIBRESOLV
@@ -2418,6 +2419,22 @@ test_fo_srv_LDADD = \
libsss_test_common.la \
$(NULL)
+test_ipa_subdom_util_SOURCES = \
+ src/tests/cmocka/test_ipa_subdomains_utils.c \
+ src/providers/ipa/ipa_subdomains_utils.c \
+ $(NULL)
+test_ipa_subdom_util_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_ipa_subdom_util_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(LDB_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client
@@ -2761,6 +2778,7 @@ libsss_ipa_la_SOURCES = \
src/providers/ipa/ipa_subdomains.c \
src/providers/ipa/ipa_subdomains_id.c \
src/providers/ipa/ipa_subdomains_server.c \
+ src/providers/ipa/ipa_subdomains_utils.c \
src/providers/ipa/ipa_subdomains_ext_groups.c \
src/providers/ipa/ipa_views.c \
src/providers/ipa/ipa_utils.c \