summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Reichl <preichl@redhat.com>2015-01-20 18:34:44 -0500
committerJakub Hrozek <jhrozek@redhat.com>2015-03-05 20:30:43 +0100
commit13ec767e6ca3e435e119f1f07bda10eb213383f6 (patch)
treefaef47c375200d7a915e920ad63e6b223f572531 /Makefile.am
parent5a5c5cdeb92f4012fc75fd717bfea06598f68f12 (diff)
downloadsssd-13ec767e6ca3e435e119f1f07bda10eb213383f6.tar.gz
sssd-13ec767e6ca3e435e119f1f07bda10eb213383f6.tar.xz
sssd-13ec767e6ca3e435e119f1f07bda10eb213383f6.zip
SDAP: Lock out ssh keys when account naturally expires
Resolves: https://fedorahosted.org/sssd/ticket/2534 Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com> Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index a02f5679b..ba24343c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2458,16 +2458,21 @@ libsss_ldap_common_la_SOURCES = \
src/providers/ldap/sdap_domain.c \
src/providers/ldap/sdap.c \
src/util/user_info_msg.c \
- src/util/sss_ldap.c
+ src/util/sss_ldap.c \
+ $(NULL)
libsss_ldap_common_la_CFLAGS = \
- $(KRB5_CFLAGS)
+ $(KRB5_CFLAGS) \
+ $(NULL)
libsss_ldap_common_la_LIBADD = \
$(OPENLDAP_LIBS) \
$(KRB5_LIBS) \
libsss_krb5_common.la \
- libsss_idmap.la
+ libsss_idmap.la \
+ libsss_util.la \
+ $(NULL)
libsss_ldap_common_la_LDFLAGS = \
- -avoid-version
+ -avoid-version \
+ $(NULL)
if BUILD_SUDO
libsss_ldap_common_la_SOURCES += \