summaryrefslogtreecommitdiffstats
path: root/python-netaddr.spec
diff options
context:
space:
mode:
authorJohn Eckersberg <jeckersb@fedoraproject.org>2008-08-13 19:30:01 +0000
committerJohn Eckersberg <jeckersb@fedoraproject.org>2008-08-13 19:30:01 +0000
commit057d4f7f0022947815998a9586d93826f95c99fc (patch)
treede2059fc9a6e322aae0bc0d53b1339eadf17757c /python-netaddr.spec
parent48756dc50cff6ae6708df92621432bdba99630fa (diff)
downloadnetaddr-057d4f7f0022947815998a9586d93826f95c99fc.tar.gz
netaddr-057d4f7f0022947815998a9586d93826f95c99fc.tar.xz
netaddr-057d4f7f0022947815998a9586d93826f95c99fc.zip
Diffstat (limited to 'python-netaddr.spec')
-rw-r--r--python-netaddr.spec60
1 files changed, 60 insertions, 0 deletions
diff --git a/python-netaddr.spec b/python-netaddr.spec
new file mode 100644
index 0000000..20368c6
--- /dev/null
+++ b/python-netaddr.spec
@@ -0,0 +1,60 @@
+%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+
+Name: python-netaddr
+Version: 0.4
+Release: 1%{?dist}
+Summary: Network address manipulation, done Pythonically
+
+Group: Development/Libraries
+License: BSD
+URL: http://code.google.com/p/netaddr/
+Source0: http://netaddr.googlecode.com/files/netaddr-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildArch: noarch
+BuildRequires: python-devel, python-setuptools
+
+%description
+netaddr is a network address manipulation library written in pure Python.
+
+It supports the Pythonic manipulation of several common network address
+notations and standards, including :-
+
+- IP version 4
+- IP version 6
+- CIDR (Classless Inter-Domain Routing)
+- IEEE EUI-48 and EUI-64
+- MAC (Media Access Control)
+
+%prep
+%setup -q -n netaddr-%{version}
+chmod 644 tests/*
+
+
+%build
+%{__python} setup.py build
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT/%{_bindir}
+%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
+chmod 755 $RPM_BUILD_ROOT%{python_sitelib}/netaddr/__init__.py
+chmod 755 $RPM_BUILD_ROOT%{python_sitelib}/netaddr/strategy.py
+chmod 755 $RPM_BUILD_ROOT%{python_sitelib}/netaddr/address.py
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%doc GLOSSARY INSTALL LICENSE PKG-INFO README docs/api/ tests
+%{python_sitelib}/*
+
+
+%changelog
+* Mon Aug 11 2008 John Eckersberg <jeckersb@redhat.com> - 0.4-1
+- Initial packaging for Fedora
+