summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <mdehaan@redhat.com>2007-10-26 17:33:44 -0400
committerMichael DeHaan <mdehaan@redhat.com>2007-10-26 17:33:44 -0400
commit9060cccfbfa77fbc8592f07e4641514d7a740a1f (patch)
tree10b0420e6a8ab82087b2898fd96cf5764162bd75 /setup.py
parentd7f4a0ebebe416084ec726d38f485246aa88e886 (diff)
downloadfunc-9060cccfbfa77fbc8592f07e4641514d7a740a1f.tar.gz
func-9060cccfbfa77fbc8592f07e4641514d7a740a1f.tar.xz
func-9060cccfbfa77fbc8592f07e4641514d7a740a1f.zip
Adds the filetracker module, originally developed by fordship, with some tweaks. "func spec call filetracker track filename" can be
used to track a file, and "func spec call filetracker untrack filename" removes it. Then it shows up with lots of data using "func spec call filetracker inventory". Addition can also specify for the contents of data in the said files to be noted in inventory. Additionally, the inventory function can be told to return data structures instead of an easily-diffable list, and the checksums can be enabled/disabled.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7cb1bef..7675ed1 100644
--- a/setup.py
+++ b/setup.py
@@ -15,6 +15,7 @@ if __name__ == "__main__":
manpath = "share/man/man1/"
etcpath = "/etc/%s" % NAME
+ etcmodpath = "/etc/%s/modules" % NAME
initpath = "/etc/init.d/"
logpath = "/var/log/%s/" % NAME
pkipath = "/etc/pki/%s" % NAME
@@ -45,6 +46,7 @@ if __name__ == "__main__":
(initpath, ["init-scripts/certmaster"]),
(etcpath, ["etc/minion.conf"]),
(etcpath, ["etc/certmaster.conf"]),
+ (etcmodpath, []),
(manpath, ["docs/func.1.gz"]),
(manpath, ["docs/func-inventory.1.gz"]),
(manpath, ["docs/funcd.1.gz"]),