summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRobin Norwood <rnorwood@redhat.com>2007-09-25 10:38:51 -0400
committerRobin Norwood <rnorwood@redhat.com>2007-09-25 10:38:51 -0400
commit6bf3d8bee599802c95832cbdae904ffce1053938 (patch)
tree6711d28ed442ffbe5fddfdc6ccd1678ec05aa74c /setup.py
parent5024f7f62ff32345660fae783ac7a97d506fe1da (diff)
parentfca2c8e36dfec0ced3957ba8f6e62bf62a99c84b (diff)
downloadfunc-6bf3d8bee599802c95832cbdae904ffce1053938.tar.gz
func-6bf3d8bee599802c95832cbdae904ffce1053938.tar.xz
func-6bf3d8bee599802c95832cbdae904ffce1053938.zip
Merge branch 'master' of git+ssh://git.fedoraproject.org/git/hosted/func
Conflicts: func.spec setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 5 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 2049a44..d487a1a 100644
--- a/setup.py
+++ b/setup.py
@@ -10,7 +10,7 @@ NAME = "func"
VERSION = open("version", "r+").read().split()[0]
SHORT_DESC = "%s remote configuration and management api" % NAME
LONG_DESC = """
-A small pluggabe xml-rpc daemon used by %s to implement various web services hooks
+A small pluggable xml-rpc daemon used by %s to implement various web services hooks
""" % NAME
@@ -36,13 +36,12 @@ if __name__ == "__main__":
name="%s" % NAME,
version = VERSION,
author = "Lots",
- author_email = "et-mgmt-tools@redhat.com",
+ author_email = "func-list@redhat.com",
url = "https://hosted.fedoraproject.org/projects/func/",
license = "GPL",
- scripts = ["scripts/funcd",
- ],
+ scripts = ["scripts/funcd", "scripts/certmaster"],
# package_data = { '' : ['*.*'] },
- package_dir = {"%s" % NAME: "",
+ package_dir = {"%s" % NAME: "%s" % NAME,
"%s/minion" % NAME: "minion/",
"%s/minion/modules" % NAME: "modules/",
"%s/overlord" % NAME: "overlord/"
@@ -52,7 +51,7 @@ if __name__ == "__main__":
"%s/overlord" % NAME,
"%s/minion/modules" % NAME
],
- data_files = [(initpath, ["init-scripts/funcd"]),
+ data_files = [(initpath, ["init-scripts/funcd", "init-scripts/certmaster"]),
(etcpath, ["settings",]),
(etcpathdb, []),
(logpath, []),