summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAdrian Likins <alikins@redhat.com>2008-04-22 14:36:17 -0400
committerAdrian Likins <alikins@redhat.com>2008-04-22 14:36:17 -0400
commitece4c159e4fd726a70b1da25821493fb8a90c8b3 (patch)
treebb91bf01af39b1caf4b36efdb8a5d2373d52ddce /setup.py
parente92972a02d0e506cb7780694642137201421a74a (diff)
downloadcertmaster-ece4c159e4fd726a70b1da25821493fb8a90c8b3.tar.gz
certmaster-ece4c159e4fd726a70b1da25821493fb8a90c8b3.tar.xz
certmaster-ece4c159e4fd726a70b1da25821493fb8a90c8b3.zip
apply triggers patch from Steve Salevan <ssalevan@redhat.com>
Steves comments: Adding in triggering functionality, changed specfile and MANIFEST.in to reflect changes. Added sub_process.py file to facilitate the subprocesses necessary for triggering to work. Modified certmaster.py to add trigger points.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bd1cf53..e47e1b0 100644
--- a/setup.py
+++ b/setup.py
@@ -18,6 +18,7 @@ if __name__ == "__main__":
initpath = "/etc/init.d/"
logpath = "/var/log/%s/" % NAME
certdir = "/var/lib/%s/" % NAME
+ trigpath = "/var/lib/%s/triggers/"% NAME
pkipath = "/etc/pki/%s" % NAME
rotpath = "/etc/logrotate.d"
aclpath = "%s/minion-acl.d" % etcpath
@@ -48,7 +49,13 @@ if __name__ == "__main__":
(certdir, []),
(etcpath, []),
(pkipath, []),
- (aclpath, [])
+ (aclpath, []),
+ ("%s/sign/pre/" % trigpath, []),
+ ("%s/sign/post/" % trigpath, []),
+ ("%s/remove/pre/" % trigpath, []),
+ ("%s/remove/post/" % trigpath, []),
+ ("%s/request/pre/" % trigpath, []),
+ ("%s/request/post/" % trigpath, []),
],
description = SHORT_DESC,
long_description = LONG_DESC