summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index df32f4f..01866f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
## Process this file with automake to produce Makefile.in
## A Makefile.in is supplied, in case you do not have automake.
-## $Id: Makefile.am,v 1.19 2004/01/10 22:47:29 heas Exp $
+## $Id: Makefile.am,v 1.20 2004/01/13 17:24:49 heas Exp $
##
## Copyright (C) 1997-2004 by Terrapin Communications, Inc.
## All rights reserved.
@@ -37,5 +37,9 @@ SUBDIRS = . include etc bin man share
# sysconfdir is here because etc/Makefile uses a script to be careful about
# installing rancid.conf, not over-writing an existing one.
+DIRS2_CREATE=$(prefix) $(sysconfdir)
+if MK_LCLSTATEDIR
+DIRS2_CREATE+=$(localstatedir)
+endif
install-data-hook:
- $(mkinstalldirs) $(prefix) $(localstatedir) $(sysconfdir);
+ $(mkinstalldirs) $(DIRS2_CREATE);