summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am51
1 files changed, 32 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 6ad5316..df32f4f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,28 +1,41 @@
## Process this file with automake to produce Makefile.in
+## A Makefile.in is supplied, in case you do not have automake.
+
+## $Id: Makefile.am,v 1.19 2004/01/10 22:47:29 heas Exp $
+##
+## Copyright (C) 1997-2004 by Terrapin Communications, Inc.
+## All rights reserved.
+##
+## This software may be freely copied, modified and redistributed
+## without fee for non-commerical purposes provided that this license
+## remains intact and unmodified with any RANCID distribution.
+##
+## There is no warranty or other guarantee of fitness of this software.
+## It is provided solely "as is". The author(s) disclaim(s) all
+## responsibility and liability with respect to this software's usage
+## or its effect upon hardware, computer systems, other software, or
+## anything else.
+##
+## Except where noted otherwise, rancid was written by and is maintained by
+## Henry Kilmer, John Heasley, Andrew Partan, and Pete Whiting.
+##
AUTOMAKE_OPTIONS=foreign no-dependencies
@SET_MAKE@
-EXTRA_DIST = BUGS CHANGES COPYING FAQ README Todo cloginrc.sample configure \
- install-sh \
- mkinstalldirs Makefile.in Todo
+pkgdata_DATA = COPYING CHANGES FAQ README README.lg UPGRADING cloginrc.sample
+EXTRA_DIST = BUGS Todo configure install-sh \
+ mkinstalldirs Makefile.in Todo $(pkgdata_DATA)
#DIST_COMMON =
# '.' is here (and at the beginnging of the macro) so that distclean-recursive
-# will run make distclean in . after the other dirs (preserving Makefile)
-SUBDIRS = . include bin man util
-
-all:
-
-# install-exec-local:
-# $(mkinstalldirs) $(prefix) $(prefix)/bin $(prefix)/man $(prefix)/util $(prefix)/util/lg
-
-install-exec-local:
- $(mkinstalldirs) $(prefix)/util $(prefix)/util/lg
-
-install:
- for file in CHANGES README cloginrc.sample ; do \
- $(INSTALL_DATA) $$file $(prefix); \
- done
-
+# will run make distclean in . after the other dirs (preserving Makefile) and
+# mkinstalldirs will create the install destination before descending into
+# the subdirs.
+SUBDIRS = . include etc bin man share
+
+# sysconfdir is here because etc/Makefile uses a script to be careful about
+# installing rancid.conf, not over-writing an existing one.
+install-data-hook:
+ $(mkinstalldirs) $(prefix) $(localstatedir) $(sysconfdir);