summaryrefslogtreecommitdiffstats
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorTar Committer <tar@ocjtech.us>2004-01-12 03:17:26 +0000
committerTar Committer <tar@ocjtech.us>2004-01-12 03:17:26 +0000
commit989312339ea2e16579803a48700628c5469e327a (patch)
tree967ee77195819d70f2dc675444e92340bb98e0d6 /etc/Makefile.am
parentff168ecfe045c690c24d5bbc5a3062bf9d64120c (diff)
downloadrancid-989312339ea2e16579803a48700628c5469e327a.tar.gz
rancid-989312339ea2e16579803a48700628c5469e327a.tar.xz
rancid-989312339ea2e16579803a48700628c5469e327a.zip
Imported from rancid-2.3.rc1.tar.gz.rancid-2.3.rc1
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am77
1 files changed, 77 insertions, 0 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
new file mode 100644
index 0000000..e44e781
--- /dev/null
+++ b/etc/Makefile.am
@@ -0,0 +1,77 @@
+## Process this file with automake to produce Makefile.in
+## A Makefile.in is supplied, in case you do not have automake.
+
+## $Id: Makefile.am,v 1.10 2004/01/11 03:43:50 heas Exp $
+##
+## Copyright (C) 1997-2004 by Terrapin Communications, Inc.
+## All rights reserved.
+##
+## This software may be freely copied, modified and redistributed
+## without fee for non-commerical purposes provided that this license
+## remains intact and unmodified with any RANCID distribution.
+##
+## There is no warranty or other guarantee of fitness of this software.
+## It is provided solely "as is". The author(s) disclaim(s) all
+## responsibility and liability with respect to this software's usage
+## or its effect upon hardware, computer systems, other software, or
+## anything else.
+##
+## Except where noted otherwise, rancid was written by and is maintained by
+## Henry Kilmer, John Heasley, Andrew Partan, Pete Whiting, and Austin Schutz.
+##
+
+#AUTOMAKE_OPTIONS=foreign no-dependencies
+AUTOMAKE_OPTIONS=foreign
+
+pkgdata_DATA= lg.conf.sample rancid.conf.sample
+EXTRA_DIST= $(pkgdata_DATA:%=%.in)
+
+CLEANFILES= $(pkgdata_DATA)
+
+install-data-local: all
+ @if test -f $(sysconfdir)/rancid.conf ; then \
+ echo ""; \
+ echo "WARNING: *** $(sysconfdir)/rancid.conf exists. See "; \
+ echo " *** $(pkgdatadir)/rancid.conf.sample for new"; \
+ echo " *** examples."; \
+ echo ""; \
+ else \
+ $(INSTALL_DATA) rancid.conf.sample $(sysconfdir)/rancid.conf; \
+ fi; \
+ if test -f $(sysconfdir)/lg.conf ; then \
+ echo ""; \
+ echo "WARNING: *** $(sysconfdir)/lg.conf exists. See "; \
+ echo " *** $(pkgdatadir)/lg.conf.sample for new"; \
+ echo " *** examples."; \
+ echo ""; \
+ else \
+ $(INSTALL_DATA) lg.conf.sample $(sysconfdir)/lg.conf; \
+ fi;
+
+#clean:
+# rm -f Makefile rancid.conf $(BIN_DATAS) $(BIN_PROGS)
+
+# auto_edit does the autoconf variable substitution. This allows the
+# substitution to have the full expansion of the variables, e.g.: $sysconfdir
+# will be /prefix/etc instead of ${prefix}/etc.
+#
+# This is a bit of a PITA, but is the method recommended by the autoconf
+# documentation.
+auto_edit = sed \
+ -e 's,@bindir\@,$(bindir),g' \
+ -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@localstatedir\@,$(localstatedir),g' \
+ -e 's,@sysconfdir\@,$(sysconfdir),g' \
+ -e 's,@EXPECT_PATH\@,$(EXPECT_PATH),g' \
+ -e 's,@PERLV_PATH\@,$(PERLV_PATH),g' \
+ -e 's,@ENV_PATH\@,$(ENV_PATH),g'
+
+lg.conf.sample: Makefile $(srcdir)/lg.conf.sample.in
+ rm -f lg.conf.sample lg.conf.sample.tmp; \
+ $(auto_edit) $(srcdir)/lg.conf.sample.in >lg.conf.sample.tmp; \
+ mv lg.conf.sample.tmp lg.conf.sample
+
+rancid.conf.sample: Makefile $(srcdir)/rancid.conf.sample.in
+ rm -f rancid.conf.sample rancid.conf.sample.tmp; \
+ $(auto_edit) $(srcdir)/rancid.conf.sample.in >rancid.conf.sample.tmp; \
+ mv rancid.conf.sample.tmp rancid.conf.sample