summaryrefslogtreecommitdiffstats
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorTar Committer <tar@ocjtech.us>2004-03-14 17:00:09 +0000
committerTar Committer <tar@ocjtech.us>2004-03-14 17:00:09 +0000
commit381d322caf5928732f3d478d80e70acfccd67f99 (patch)
treed52aa26f9698cd869eca3f09661bfc05a7008a28 /etc/Makefile.am
parent989312339ea2e16579803a48700628c5469e327a (diff)
downloadrancid-381d322caf5928732f3d478d80e70acfccd67f99.tar.gz
rancid-381d322caf5928732f3d478d80e70acfccd67f99.tar.xz
rancid-381d322caf5928732f3d478d80e70acfccd67f99.zip
Imported from rancid-2.3.tar.gz.rancid-2.3
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
index e44e781..10edcad 100644
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -1,7 +1,7 @@
## Process this file with automake to produce Makefile.in
## A Makefile.in is supplied, in case you do not have automake.
-## $Id: Makefile.am,v 1.10 2004/01/11 03:43:50 heas Exp $
+## $Id: Makefile.am,v 1.11 2004/01/13 18:02:00 heas Exp $
##
## Copyright (C) 1997-2004 by Terrapin Communications, Inc.
## All rights reserved.
@@ -28,8 +28,13 @@ EXTRA_DIST= $(pkgdata_DATA:%=%.in)
CLEANFILES= $(pkgdata_DATA)
+if CONF_INSTALL
+DO_CONF_INSTALL=yes
+endif
+
install-data-local: all
- @if test -f $(sysconfdir)/rancid.conf ; then \
+ @if test "$(DO_CONF_INSTALL)" = "yes"; then \
+ if test -f $(sysconfdir)/rancid.conf ; then \
echo ""; \
echo "WARNING: *** $(sysconfdir)/rancid.conf exists. See "; \
echo " *** $(pkgdatadir)/rancid.conf.sample for new"; \
@@ -46,7 +51,8 @@ install-data-local: all
echo ""; \
else \
$(INSTALL_DATA) lg.conf.sample $(sysconfdir)/lg.conf; \
- fi;
+ fi; \
+ fi
#clean:
# rm -f Makefile rancid.conf $(BIN_DATAS) $(BIN_PROGS)