summaryrefslogtreecommitdiffstats
path: root/utils/nfsdcld/Makefile.am
diff options
context:
space:
mode:
authorJeff Layton <jlayton@redhat.com>2012-04-26 11:43:30 -0400
committerSteve Dickson <steved@redhat.com>2012-04-26 13:25:04 -0400
commit3e859abefffafd8718b5f1f76da7b129fc18e281 (patch)
tree7e5fe58c202e3f3706735a20580ca58c88ba898f /utils/nfsdcld/Makefile.am
parentdfebe7f4f25a12b615195f339192fa8837d9b5c9 (diff)
downloadnfs-utils-3e859abefffafd8718b5f1f76da7b129fc18e281.tar.gz
nfs-utils-3e859abefffafd8718b5f1f76da7b129fc18e281.tar.xz
nfs-utils-3e859abefffafd8718b5f1f76da7b129fc18e281.zip
nfsdcld: add routines for a sqlite backend database
Rather than roll our own "storage engine", use sqlite instead. It fits the bill nicely as it does: - durable on-disk storage - the ability to constrain record uniqueness - a facility for collating and searching the host records ...it does add a build dependency to nfs-utils, but almost all modern distros provide those packages. The current incarnation of this code dynamically links against a provided sqlite library, but we could also consider including their single-file "amalgamation" to reduce dependencies (though with all the caveats that that entails). Signed-off-by: Jeff Layton <jlayton@redhat.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'utils/nfsdcld/Makefile.am')
-rw-r--r--utils/nfsdcld/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/nfsdcld/Makefile.am b/utils/nfsdcld/Makefile.am
index ed7ed42..8e4f2ab 100644
--- a/utils/nfsdcld/Makefile.am
+++ b/utils/nfsdcld/Makefile.am
@@ -6,9 +6,9 @@
AM_CFLAGS += -D_LARGEFILE64_SOURCE
sbin_PROGRAMS = nfsdcld
-nfsdcld_SOURCES = nfsdcld.c
+nfsdcld_SOURCES = nfsdcld.c sqlite.c
-nfsdcld_LDADD = ../../support/nfs/libnfs.a $(LIBEVENT)
+nfsdcld_LDADD = ../../support/nfs/libnfs.a $(LIBEVENT) $(LIBSQLITE)
MAINTAINERCLEANFILES = Makefile.in