summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Layton <jlayton@redhat.com>2012-04-26 11:29:22 -0400
committerSteve Dickson <steved@redhat.com>2012-04-26 13:25:03 -0400
commitdfebe7f4f25a12b615195f339192fa8837d9b5c9 (patch)
tree8b4ffc7a5c267b44949f5e23f589ef5c117ba237 /configure.ac
parentaff33d2e1fd7b4c8d91ff0cc5ea6ec4da125e1e0 (diff)
downloadnfs-utils-dfebe7f4f25a12b615195f339192fa8837d9b5c9.tar.gz
nfs-utils-dfebe7f4f25a12b615195f339192fa8837d9b5c9.tar.xz
nfs-utils-dfebe7f4f25a12b615195f339192fa8837d9b5c9.zip
nfsdcld: add autoconf goop for sqlite
Mostly cribbed from Chuck Lever's new-statd rewrite a few years ago... This adds an autoconf test for the sqlite3 library and includes. If they're not working properly and nfsdcld was enabled, then configure will error out. Signed-off-by: Jeff Layton <jlayton@redhat.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9ffb68..0d29dc7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -266,6 +266,15 @@ if test "$enable_nfsv4" = yes; then
dnl check for the keyutils libraries and headers
AC_KEYUTILS
+ dnl Check for sqlite3
+ AC_SQLITE3_VERS
+
+ if test "$enable_nfsdcld" = "yes"; then
+ if test "$libsqlite3_cv_is_recent" != "yes" ; then
+ AC_MSG_ERROR([nfsdcld requires sqlite3])
+ fi
+ fi
+
AM_CONDITIONAL(CONFIG_NFSDCLD, [test "$enable_nfsdcld" = "yes" ])
dnl librpcsecgss already has a dependency on libgssapi,