summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Layton <jlayton@redhat.com>2012-11-08 14:36:56 -0500
committerSteve Dickson <steved@redhat.com>2012-11-11 18:01:23 -0500
commit37ebcfc42478bbbf5784504072b682037352a90e (patch)
tree40e7b119518a2dd04e5960763679690de02d8546 /configure.ac
parentb20a49b5e7ca0d42f752d36a9dc0f2197243d6f0 (diff)
downloadnfs-utils-37ebcfc42478bbbf5784504072b682037352a90e.tar.gz
nfs-utils-37ebcfc42478bbbf5784504072b682037352a90e.tar.xz
nfs-utils-37ebcfc42478bbbf5784504072b682037352a90e.zip
nfsdcltrack: rename the nfsdcld directory and options to nfsdcltrack
We'll soon be adding a new nfsdcltrack program, at which point it won't make much sense to call this directory and the config option "nfsdcld". Rename it to be a bit more generic. While we're at it, change the default for --enable-cltrack to "yes". When we introduce the one-shot program, we're going to want to build it by default anyway. Signed-off-by: Jeff Layton <jlayton@redhat.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index a174bf4..825682c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -185,11 +185,11 @@ else
AM_CONDITIONAL(MOUNT_CONFIG, [test "$enable_mount" = "yes"])
fi
-AC_ARG_ENABLE(nfsdcld,
- [AC_HELP_STRING([--enable-nfsdcld],
- [Create nfsdcld NFSv4 clientid tracking daemon. @<:@default=no@:>@])],
- enable_nfsdcld=$enableval,
- enable_nfsdcld="no")
+AC_ARG_ENABLE(nfsdcltrack,
+ [AC_HELP_STRING([--enable-nfsdcltrack],
+ [enable NFSv4 clientid tracking programs @<:@default=yes@:>@])],
+ enable_nfsdctrack=$enableval,
+ enable_nfsdcltrack="yes")
dnl Check for TI-RPC library and headers
AC_LIBTIRPC
@@ -269,12 +269,12 @@ if test "$enable_nfsv4" = yes; then
dnl Check for sqlite3
AC_SQLITE3_VERS
- if test "$enable_nfsdcld" = "yes"; then
+ if test "$enable_nfsdcltrack" = "yes"; then
AC_CHECK_HEADERS([libgen.h sys/inotify.h], ,
- AC_MSG_ERROR([Cannot find header needed for nfsdcld]))
+ AC_MSG_ERROR([Cannot find header needed for nfsdcltrack]))
if test "$libsqlite3_cv_is_recent" != "yes" ; then
- AC_MSG_ERROR([nfsdcld requires sqlite3])
+ AC_MSG_ERROR([nfsdcltrack requires sqlite-devel])
fi
fi
@@ -292,7 +292,7 @@ if test "$enable_nfsv41" = yes; then
fi
dnl enable nfsidmap when its support by libnfsidmap
-AM_CONDITIONAL(CONFIG_NFSDCLD, [test "$enable_nfsdcld" = "yes" ])
+AM_CONDITIONAL(CONFIG_NFSDCLTRACK, [test "$enable_nfsdcltrack" = "yes" ])
AM_CONDITIONAL(CONFIG_NFSIDMAP, [test "$ac_cv_header_keyutils_h$ac_cv_lib_nfsidmap_nfs4_owner_to_uid" = "yesyes"])
@@ -477,7 +477,7 @@ AC_CONFIG_FILES([
tools/nfs-iostat/Makefile
utils/Makefile
utils/blkmapd/Makefile
- utils/nfsdcld/Makefile
+ utils/nfsdcltrack/Makefile
utils/exportfs/Makefile
utils/gssd/Makefile
utils/idmapd/Makefile