summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2009-08-05 16:10:01 -0400
committerSteve Dickson <steved@redhat.com>2009-08-16 16:53:30 -0400
commit1d1f701656f86c54b07e7fd9481d1f45018cfddb (patch)
tree2d7187c9bed5bf8dd59cace8a503cc05781a1a45 /configure.ac
parent9350a97a266ada8d8b3282cf4248e3b9ffdc0058 (diff)
downloadnfs-utils-1d1f701656f86c54b07e7fd9481d1f45018cfddb.tar.gz
nfs-utils-1d1f701656f86c54b07e7fd9481d1f45018cfddb.tar.xz
nfs-utils-1d1f701656f86c54b07e7fd9481d1f45018cfddb.zip
Adds '--enable-mountconfig' configuration flag that will
enabled mount to read from a configuration file. The default value is disabled (or no) Adds '--with-mountfile' configuration flag that is used when mountconf is enabled to define the configuration file name. The default is /etc/nfsmount.conf. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e0ca70e..1b653e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,6 +136,31 @@ AC_ARG_ENABLE(ipv6,
AC_SUBST(enable_ipv6)
AM_CONDITIONAL(CONFIG_IPV6, [test "$enable_ipv6" = "yes"])
+if test "$enable_mount" = yes; then
+ AC_ARG_ENABLE(mountconfig,
+ [AC_HELP_STRING([--enable-mountconfig],
+ [enable mount to use a configuration file])],
+ mountconfig=$enableval,
+ mountconfig=no)
+ if test "$enable_mountconfig" = yes; then
+ AC_DEFINE(MOUNT_CONFIG, 1,
+ [Define this if you want mount to read a configuration file])
+ AC_ARG_WITH(mountfile,
+ [AC_HELP_STRING([--with-mountfile=filename],
+ [Using filename as the NFS mount options file [/etc/nfsmounts.conf]]
+ )],
+ mountfile=$withval,
+ mountfile=/etc/nfsmount.conf)
+ AC_SUBST(mountfile)
+ AC_DEFINE_UNQUOTED(MOUNTOPTS_CONFFILE, "$mountfile",
+ [This defines the location of the NFS mount configuration file])
+ else
+ enable_mountconfig=
+ fi
+ AC_SUBST(enable_mountconfig)
+ AM_CONDITIONAL(MOUNT_CONFIG, [test "$enable_mountconfig" = "yes"])
+fi
+
dnl Check for TI-RPC library and headers
AC_LIBTIRPC