summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNeil Brown <neilb@suse.de>2007-03-16 14:32:32 +1100
committerNeil Brown <neilb@suse.de>2007-03-16 14:32:32 +1100
commit51a0e4c4d8aa871e87d8c8749d35b64ccb669506 (patch)
tree7d8fa13c4a0c642a84b05aa037168e002d2d973c /Makefile.am
parenta4fe85a8e98655aa9be534258074312446d337ab (diff)
downloadnfs-utils-51a0e4c4d8aa871e87d8c8749d35b64ccb669506.tar.gz
nfs-utils-51a0e4c4d8aa871e87d8c8749d35b64ccb669506.tar.xz
nfs-utils-51a0e4c4d8aa871e87d8c8749d35b64ccb669506.zip
Allow 'make install' to be run as non-root.
Providing write access to the DESTDIR is ok, we shouldn't fail the install just because 'chown' fails.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c04e9de..ec8e832 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,7 +50,7 @@ install-data-hook:
mkdir -p $(DESTDIR)$(statedir)/sm $(DESTDIR)$(statedir)/sm.bak
touch $(DESTDIR)$(statedir)/state
chmod go-rwx $(DESTDIR)$(statedir)/sm $(DESTDIR)$(statedir)/sm.bak $(DESTDIR)$(statedir)/state
- chown $(statduser) $(DESTDIR)$(statedir)/sm $(DESTDIR)$(statedir)/sm.bak $(DESTDIR)$(statedir)/state
+ -chown $(statduser) $(DESTDIR)$(statedir)/sm $(DESTDIR)$(statedir)/sm.bak $(DESTDIR)$(statedir)/state
uninstall-hook:
rm $(DESTDIR)$(statedir)/xtab