summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/configure.in b/src/configure.in
index 9e9c94ff99..7154f686bd 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -1219,7 +1219,7 @@ AC_ARG_WITH([system-verto],
[AC_HELP_STRING([--with-system-verto], [always use system verto library])],
[], [with_system_verto=default])
VERTO_CFLAGS=
-VERTO_LIBS="-lverto-k5ev -lverto"
+VERTO_LIBS="-lverto"
VERTO_VERSION=k5
if test "x$with_system_verto" != xno; then
if verto_cflags=`pkg-config --cflags libverto 2>&1`; then
@@ -1227,7 +1227,7 @@ if test "x$with_system_verto" != xno; then
VERTO_LIBS=`pkg-config --libs libverto`
VERTO_VERSION=sys
else
- AC_CHECK_LIB([verto], [verto_run], [VERTO_VERSION=sys; VERTO_LIBS=-lverto],
+ AC_CHECK_LIB([verto], [verto_run], [VERTO_VERSION=sys],
[if test "x$with_system_verto" = xyes; then
AC_MSG_ERROR([cannot detect system libverto])
fi])
@@ -1237,7 +1237,6 @@ if test "x$VERTO_VERSION" = xsys; then
AC_MSG_NOTICE([Using system libverto])
else
AC_MSG_RESULT([Using built-in libverto])
- AC_DEFINE([INTERNAL_VERTO],[1],[Define if using bundled libverto])
fi
AC_SUBST([VERTO_CFLAGS])
AC_SUBST([VERTO_LIBS])
@@ -1295,7 +1294,7 @@ AC_CONFIG_FILES(krb5-config, [chmod +x krb5-config])
V5_AC_OUTPUT_MAKEFILE(.
util util/support util/profile util/profile/testmod util/send-pr
- util/verto util/k5ev
+ util/verto
lib lib/kdb