summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2013-06-11 15:54:37 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2013-06-11 15:54:37 +0200
commit7c0967fc8cb24d78171c7d3cb553ba40e5adcc36 (patch)
treea3c1c462eef23495db3c2576e978be163414bcd6 /configure.ac
parent16df26cf5fbb83482196cfb4f8ace774912b7f34 (diff)
downloadvirt-viewer-7c0967fc8cb24d78171c7d3cb553ba40e5adcc36.tar.gz
virt-viewer-7c0967fc8cb24d78171c7d3cb553ba40e5adcc36.tar.xz
virt-viewer-7c0967fc8cb24d78171c7d3cb553ba40e5adcc36.zip
ovirt: Set host subject if needed
For some VMs, setting host subject on SpiceSession is needed to be able to connect to it using SPICE/SSL. Until recently, this was not exposed in oVirt REST API/libgovirt. Since oVirt 3.2/libgovirt 0.1.0, the host subject is available, this patch makes use of it. This should fix connection to oVirt VMs that were migrated to a different host than the one they were started on.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c7fb5c8..4cf6a60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -178,7 +178,7 @@ AC_ARG_WITH([ovirt],
AS_HELP_STRING([--without-ovirt], [Ignore presence of librest and disable oVirt support]))
AS_IF([test "x$with_ovirt" != "xno"],
- [PKG_CHECK_MODULES([OVIRT], [govirt-1.0],
+ [PKG_CHECK_MODULES([OVIRT], [govirt-1.0 >= 0.1.0],
[have_ovirt=yes], [have_ovirt=no])],
[have_ovirt=no])