summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2013-02-21 18:10:48 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2013-04-12 19:45:38 +0200
commit67c8c3790f1eaa0c40c5397abca03abc83504686 (patch)
tree4ea88727a3d2fef19db5c62ffc765dadce4456bd /configure.ac
parent010a71a7484653ae16b91658fdf7cadb06d3a7a4 (diff)
downloadvirt-viewer-67c8c3790f1eaa0c40c5397abca03abc83504686.tar.gz
virt-viewer-67c8c3790f1eaa0c40c5397abca03abc83504686.tar.xz
virt-viewer-67c8c3790f1eaa0c40c5397abca03abc83504686.zip
Add oVirt support
This commit adds support for ovirt:// URIs. It does so by using libgovirt to get the spice/vnc connection information through oVirt xmlrpc API.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b1d532b..32d5524 100644
--- a/configure.ac
+++ b/configure.ac
@@ -165,6 +165,22 @@ AS_IF([test "x$have_spice_gtk" = "xyes"],
])
AM_CONDITIONAL([HAVE_SPICE_GTK], [test "x$have_spice_gtk" = "xyes"])
+AC_ARG_WITH([ovirt],
+ AS_HELP_STRING([--without-ovirt], [Ignore presence of librest and disable oVirt support]))
+
+AS_IF([test "x$with_ovirt" != "xno"],
+ [PKG_CHECK_MODULES([OVIRT], [govirt-1.0],
+ [have_ovirt=yes], [have_ovirt=no])],
+ [have_ovirt=no])
+
+AS_IF([test "x$have_ovirt" = "xyes"],
+ [AC_DEFINE([HAVE_OVIRT], 1, [Have libgovirt?])],
+ [AS_IF([test "x$with_ovirt" = "xyes"],
+ [AC_MSG_ERROR([oVirt support requested but libgovirt not found])
+ ])
+])
+AM_CONDITIONAL([HAVE_OVIRT], [test "x$have_ovirt" = "xyes"])
+
dnl Decide if this platform can support the SSH tunnel feature.
AC_CHECK_HEADERS([sys/socket.h sys/un.h windows.h])
AC_CHECK_FUNCS([fork socketpair])
@@ -222,3 +238,5 @@ AC_MSG_NOTICE([ LIBXML2: $LIBXML2_CFLAGS $LIBXML2_LIBS])
AC_MSG_NOTICE([])
AC_MSG_NOTICE([ LIBVIRT: $LIBVIRT_CFLAGS $LIBVIRT_LIBS])
AC_MSG_NOTICE([])
+AC_MSG_NOTICE([ OVIRT: $OVIRT_CFLAGS $OVIRT_LIBS])
+AC_MSG_NOTICE([])