summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-04-02 13:43:17 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2014-04-04 14:49:20 +0200
commit3232dd743bb68f5723a0f2167a330053b463a525 (patch)
tree3d4237469cf32010bcb03be0e6857fdc89375f63 /configure.ac
parentf1cadccb9a765932fc338f9330ef58d08f737101 (diff)
downloadvirt-viewer-3232dd743bb68f5723a0f2167a330053b463a525.tar.gz
virt-viewer-3232dd743bb68f5723a0f2167a330053b463a525.tar.xz
virt-viewer-3232dd743bb68f5723a0f2167a330053b463a525.zip
build-sys: Always prepend '-' to build id
When using the --with-buildid configure paramater, the build id which is substituted in the MSI wxs file is automatically prepended by a '-', but the build id which is used in the C files does not get this '-' automatically. Currently, the linux and mingw spec files prepend a '-' on their own to the --with-buildid argument, but this causes the MSI installer to show 2 '-' during installation: "Please wait while Windows configures VirtViewer 0.6.0--1" This commit always prepends a '-' to the buildid strings, and removes the '-' from the spec files. This is to ensure the separator between version number and buildid is not forgotten, which could give a confusing version number.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7a00bf4..f966688 100644
--- a/configure.ac
+++ b/configure.ac
@@ -211,10 +211,11 @@ if test "x$have_gtk_vnc" != "xyes" && test "x$have_spice_gtk" != "xyes"; then
fi
AC_ARG_WITH([buildid],
- AS_HELP_STRING([--with-buildid=id], [Set additional build version details]))
-AC_DEFINE_UNQUOTED([BUILDID], "$with_buildid", [Build version details])
-if test "x$with_buildid" != x; then
- AC_SUBST([BUILDID], "-$with_buildid")
+ AS_HELP_STRING([--with-buildid=id], [Set additional build version details]),
+ [buildid="-$with_buildid"], [buildid=""])
+AC_DEFINE_UNQUOTED([BUILDID], "$buildid", [Build version details])
+if test "x$buildid" != x; then
+ AC_SUBST([BUILDID], "$buildid")
fi
major=`echo $PACKAGE_VERSION | cut -d. -f1`