summaryrefslogtreecommitdiffstats
path: root/server/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/tests/Makefile.am')
-rw-r--r--server/tests/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/server/tests/Makefile.am b/server/tests/Makefile.am
index 09fdc264..f91dfa46 100644
--- a/server/tests/Makefile.am
+++ b/server/tests/Makefile.am
@@ -1,14 +1,19 @@
NULL =
-INCLUDES = \
- -I.. \
- $(PROTOCOL_CFLAGS) \
- $(SPICE_NONPKGCONFIG_CFLAGS) \
+INCLUDES = \
+ -I.. \
+ -I../../common \
+ $(PROTOCOL_CFLAGS) \
+ $(SPICE_NONPKGCONFIG_CFLAGS) \
$(NULL)
LDFLAGS = -L../.libs -lspice-server
-noinst_PROGRAMS = test_just_sockets_no_ssl test_empty_success test_fail_on_null_core_interface
+noinst_PROGRAMS = test_just_sockets_no_ssl test_empty_success test_fail_on_null_core_interface test_display_no_ssl
+
+test_display_no_ssl_SOURCES = test_display_no_ssl.c basic_event_loop.c
+
+test_display_no_ssl_LDFLAGS = $(LDFLAGS)
test_just_sockets_no_ssl_SOURCES = test_just_sockets_no_ssl.c basic_event_loop.c basic_event_loop.h