summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 73a886fd..81649a4f 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -6,7 +6,6 @@ INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/common \
-DRED_STATISTICS \
- -DSW_CANVAS_IMAGE_CACHE \
$(Z_LIBS) \
$(CELT051_CFLAGS) \
$(PIXMAN_CFLAGS) \
@@ -89,6 +88,8 @@ libspice_server_la_SOURCES = \
red_worker.h \
reds.c \
reds.h \
+ reds_sw_canvas.c \
+ reds_sw_canvas.h \
snd_worker.c \
snd_worker.h \
spice-experimental.h \
@@ -105,6 +106,13 @@ libspice_server_la_SOURCES += \
$(NULL)
endif
+if SUPPORT_GL
+libspice_server_la_SOURCES += \
+ reds_gl_canvas.c \
+ reds_gl_canvas.h \
+ $(NULL)
+endif
+
if SUPPORT_SMARTCARD
libspice_server_la_SOURCES += \
smartcard.c \