summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am81
1 files changed, 81 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
new file mode 100644
index 00000000..e6ffab40
--- /dev/null
+++ b/server/Makefile.am
@@ -0,0 +1,81 @@
+NULL =
+
+INCLUDES = \
+ -I. \
+ -I$(top_srcdir)/common \
+ $(FFMPEG_CFLAGS) \
+ $(QCAIRO_CFLAGS) \
+ $(GL_CFLAGS) \
+ $(LOG4CPP_CFLAGS) \
+ $(SSL_CFLAGS) \
+ $(CELT051_CFLAGS) \
+ -DCAIRO_CANVAS_IMAGE_CACHE \
+ -DRED_STATISTICS \
+ $(WARN_CFLAGS) \
+ $(VISIBILITY_HIDDEN_CFLAGS) \
+ $(NULL)
+
+COMMON_SRCS = \
+ $(top_srcdir)/common/cairo_canvas.c \
+ $(top_srcdir)/common/gl_canvas.c \
+ $(top_srcdir)/common/region.c \
+ $(top_srcdir)/common/glc.c \
+ $(top_srcdir)/common/ogl_ctx.c \
+ $(top_srcdir)/common/rop3.c \
+ $(top_srcdir)/common/quic.c \
+ $(top_srcdir)/common/lz.c \
+ $(top_srcdir)/common/canvas_utils.c \
+ $(NULL)
+
+lib_LTLIBRARIES = libspice.la
+
+libspice_la_LDFLAGS = \
+ -version-number $(SPICE_LT_VERSION) \
+ -no-undefined \
+ $(NULL)
+
+libspice_la_LIBADD = \
+ $(GL_LIBS) \
+ $(FFMPEG_LIBS) \
+ $(QCAIRO_LIBS) \
+ $(SSL_LIBS) \
+ $(CELT051_LIBS) \
+ $(LIBRT) \
+ $(NULL)
+
+libspice_la_SOURCES = \
+ glz_encoder.c \
+ glz_encoder_config.h \
+ glz_encoder_dictionary.c \
+ glz_encoder_dictionary.h \
+ glz_encoder_dictionary_protected.h \
+ glz_encoder.h \
+ red_bitmap_utils.h \
+ red_client_cache.h \
+ red_client_shared_cache.h \
+ red_common.h \
+ red_dispatcher.c \
+ red_dispatcher.h \
+ reds.c \
+ reds.h \
+ stat.h \
+ red_worker.c \
+ red_worker.h \
+ red_yuv.h \
+ snd_worker.c \
+ snd_worker.h \
+ spice.h \
+ vd_interface.h \
+ $(COMMON_SRCS) \
+ $(NULL)
+
+libspiceincludedir = $(includedir)/libspice
+libspiceinclude_HEADERS = \
+ spice.h \
+ vd_interface.h \
+ $(NULL)
+
+EXTRA_DIST = \
+ glz_encode_match_tmpl.c \
+ glz_encode_tmpl.c \
+ $(NULL)