summaryrefslogtreecommitdiffstats
path: root/common/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'common/configure.ac')
-rw-r--r--common/configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/common/configure.ac b/common/configure.ac
new file mode 100644
index 00000000..c375809f
--- /dev/null
+++ b/common/configure.ac
@@ -0,0 +1,27 @@
+AC_PREREQ([2.57])
+
+m4_define([SPICE_MAJOR], 0)
+m4_define([SPICE_MINOR], 4)
+m4_define([SPICE_MICRO], 1)
+
+AC_INIT(spice-common, [SPICE_MAJOR.SPICE_MINOR.SPICE_MICRO], [], spice-common)
+
+AC_CONFIG_MACRO_DIR([m4])
+
+m4_include(../configure.ac.shared)
+
+AC_CONFIG_FILES([Makefile linux/ffmpeg_inc.h])
+AC_OUTPUT
+
+dnl ==========================================================================
+echo "
+
+ Spice Common $VERSION
+ ==============
+
+ prefix: ${prefix}
+ c compiler: ${CC}
+ c++ compiler: ${CXX}
+
+ Now type 'make' to build $PACKAGE
+"