summaryrefslogtreecommitdiffstats
path: root/client/x11/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'client/x11/Makefile.am')
-rw-r--r--client/x11/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/client/x11/Makefile.am b/client/x11/Makefile.am
index dc83f58c..101f6ddf 100644
--- a/client/x11/Makefile.am
+++ b/client/x11/Makefile.am
@@ -109,8 +109,6 @@ RED_COMMON_SRCS = \
$(CLIENT_DIR)/hot_keys.cpp \
$(CLIENT_DIR)/hot_keys.h \
$(CLIENT_DIR)/threads.cpp \
- $(CLIENT_DIR)/tunnel_channel.cpp \
- $(CLIENT_DIR)/tunnel_channel.h \
$(CLIENT_DIR)/utils.cpp \
$(CLIENT_DIR)/utils.h \
$(CLIENT_DIR)/zlib_decoder.cpp \
@@ -118,6 +116,15 @@ RED_COMMON_SRCS = \
$(CLIENT_DIR)/icon.h \
$(NULL)
+if SUPPORT_TUNNEL
+RED_TUNNEL_SRCS = \
+ $(CLIENT_DIR)/tunnel_channel.cpp \
+ $(CLIENT_DIR)/tunnel_channel.h \
+ $(NULL)
+else
+RED_TUNNEL_SRCS =
+endif
+
if SUPPORT_GUI
RED_GUI_SRCS = \
$(CLIENT_DIR)/gui/softrenderer.h \
@@ -127,7 +134,8 @@ RED_GUI_SRCS = \
$(CLIENT_DIR)/gui/resource_provider.h \
$(CLIENT_DIR)/gui/resource_provider.cpp \
$(CLIENT_DIR)/gui/gui.h \
- $(CLIENT_DIR)/gui/gui.cpp
+ $(CLIENT_DIR)/gui/gui.cpp \
+ $(NULL)
else
RED_GUI_SRCS =
endif
@@ -176,6 +184,7 @@ spicec_SOURCES = \
x_platform.h \
$(RED_COMMON_SRCS) \
$(RED_GUI_SRCS) \
+ $(RED_TUNNEL_SRCS) \
$(RED_OGL_SRCS) \
$(NULL)