summaryrefslogtreecommitdiffstats
path: root/server/tests/Makefile.am
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2011-08-22 15:35:37 +0100
committerAlon Levy <alevy@redhat.com>2011-08-23 17:01:14 +0300
commitb88f23363388ffec42ba3a9d16075d9f7a0357eb (patch)
treed40eb10907903a49501ef93dbb4ff6bac1c6e2ff /server/tests/Makefile.am
parent13a6c8b3a1ddf58636dda98a2146a5b5d1a4056e (diff)
downloadspice-b88f23363388ffec42ba3a9d16075d9f7a0357eb.tar.gz
spice-b88f23363388ffec42ba3a9d16075d9f7a0357eb.tar.xz
spice-b88f23363388ffec42ba3a9d16075d9f7a0357eb.zip
server/tests/basic_event_loop: multiple fixes
reuse common/ring.h ignore SIGPIPE fix handling of removed watches
Diffstat (limited to 'server/tests/Makefile.am')
-rw-r--r--server/tests/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/server/tests/Makefile.am b/server/tests/Makefile.am
index 8ec4094f..4513322d 100644
--- a/server/tests/Makefile.am
+++ b/server/tests/Makefile.am
@@ -11,16 +11,19 @@ INCLUDES = \
AM_LDFLAGS = $(top_builddir)/server/libspice-server.la
+COMMON_BASE=basic_event_loop.c basic_event_loop.h test_util.h ../../common/backtrace.c
+
+
noinst_PROGRAMS = test_just_sockets_no_ssl test_empty_success test_fail_on_null_core_interface test_display_no_ssl test_display_streaming test_playback
-test_display_streaming_SOURCES = test_display_streaming.c test_display_base.c test_display_base.h basic_event_loop.c basic_event_loop.h test_util.h
+test_display_streaming_SOURCES = test_display_streaming.c test_display_base.c test_display_base.h $(COMMON_BASE)
-test_display_no_ssl_SOURCES = test_display_no_ssl.c test_display_base.c test_display_base.h basic_event_loop.c basic_event_loop.h test_util.h
+test_display_no_ssl_SOURCES = test_display_no_ssl.c test_display_base.c test_display_base.h $(COMMON_BASE)
-test_just_sockets_no_ssl_SOURCES = test_just_sockets_no_ssl.c basic_event_loop.c basic_event_loop.h test_util.h
+test_just_sockets_no_ssl_SOURCES = test_just_sockets_no_ssl.c $(COMMON_BASE)
test_empty_success_SOURCES = test_empty_success.c
test_fail_on_null_core_interface_SOURCES = test_fail_on_null_core_interface.c
-test_playback_SOURCES = test_playback.c basic_event_loop.c basic_event_loop.h test_util.h
+test_playback_SOURCES = test_playback.c $(COMMON_BASE)