summaryrefslogtreecommitdiffstats
path: root/server/tests/Makefile.am
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2010-11-10 19:36:47 +0200
committerAlon Levy <alevy@redhat.com>2010-11-30 21:03:14 +0200
commit9002d3f0058b1dbebf207d3d24dc377ab4afa0b1 (patch)
tree9ee0e398cb7c7ea63b3561a1196390117c5843c5 /server/tests/Makefile.am
parent74b39efd6e9c43581ec385e03cefceb3febbe969 (diff)
downloadspice-9002d3f0058b1dbebf207d3d24dc377ab4afa0b1.tar.gz
spice-9002d3f0058b1dbebf207d3d24dc377ab4afa0b1.tar.xz
spice-9002d3f0058b1dbebf207d3d24dc377ab4afa0b1.zip
server/tests: add test_display_no_ssl
updates taken from spice vga mode updates, i.e. non cacheable, glz compressed (depends on whatever settings you apply to the server) opaque draw operations. + completed the SpiceCoreInterface implementation (timers) v1->v2: removed test_util.c (Hans) replaced mallocz with calloc (Hans)
Diffstat (limited to 'server/tests/Makefile.am')
-rw-r--r--server/tests/Makefile.am15
1 files changed, 10 insertions, 5 deletions
diff --git a/server/tests/Makefile.am b/server/tests/Makefile.am
index 09fdc264..f91dfa46 100644
--- a/server/tests/Makefile.am
+++ b/server/tests/Makefile.am
@@ -1,14 +1,19 @@
NULL =
-INCLUDES = \
- -I.. \
- $(PROTOCOL_CFLAGS) \
- $(SPICE_NONPKGCONFIG_CFLAGS) \
+INCLUDES = \
+ -I.. \
+ -I../../common \
+ $(PROTOCOL_CFLAGS) \
+ $(SPICE_NONPKGCONFIG_CFLAGS) \
$(NULL)
LDFLAGS = -L../.libs -lspice-server
-noinst_PROGRAMS = test_just_sockets_no_ssl test_empty_success test_fail_on_null_core_interface
+noinst_PROGRAMS = test_just_sockets_no_ssl test_empty_success test_fail_on_null_core_interface test_display_no_ssl
+
+test_display_no_ssl_SOURCES = test_display_no_ssl.c basic_event_loop.c
+
+test_display_no_ssl_LDFLAGS = $(LDFLAGS)
test_just_sockets_no_ssl_SOURCES = test_just_sockets_no_ssl.c basic_event_loop.c basic_event_loop.h