summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2011-04-20 17:50:22 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2011-05-03 14:44:10 +0200
commit2db7212175c51f4121790bfd1fd677c0b77833d5 (patch)
tree8511c736d8a6ca3c0adc43059ff47cdc53f9a980 /server/Makefile.am
parent253aa0c960ccb3fd2cd6f6b2550ef09b9cbd5d1a (diff)
downloadspice-2db7212175c51f4121790bfd1fd677c0b77833d5.tar.gz
spice-2db7212175c51f4121790bfd1fd677c0b77833d5.tar.xz
spice-2db7212175c51f4121790bfd1fd677c0b77833d5.zip
autotools: correctly build canvas-related code
spice client and spice server shares code from common/{gdi,gl,sw}_canvas.[ch]. However, while most of the code is shared, the server code wants a canvas compiled with SW_CANVAS_IMAGE_CACHE defined while the client code wants a canvas compiled with SW_CANVAS_CACHE. The initial autotools refactoring didn't take that into account, this is now fixed by this commit. After this commit, the canvas files from common/ are no longer compiled as part of the libspice-common.la convenience library. Instead, there are "proxy" canvas source files in client/ and server/ which #include the appropriate C files after defining the relevant #define for the binary that is being built. To prevent misuse of the canvas c files and headers in common/, SPICE_CANVAS_INTERNAL must be set when including the canvas headers from common/ or when building the c files from common/ otherwise the build will error out.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 73a886fd..81649a4f 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -6,7 +6,6 @@ INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/common \
-DRED_STATISTICS \
- -DSW_CANVAS_IMAGE_CACHE \
$(Z_LIBS) \
$(CELT051_CFLAGS) \
$(PIXMAN_CFLAGS) \
@@ -89,6 +88,8 @@ libspice_server_la_SOURCES = \
red_worker.h \
reds.c \
reds.h \
+ reds_sw_canvas.c \
+ reds_sw_canvas.h \
snd_worker.c \
snd_worker.h \
spice-experimental.h \
@@ -105,6 +106,13 @@ libspice_server_la_SOURCES += \
$(NULL)
endif
+if SUPPORT_GL
+libspice_server_la_SOURCES += \
+ reds_gl_canvas.c \
+ reds_gl_canvas.h \
+ $(NULL)
+endif
+
if SUPPORT_SMARTCARD
libspice_server_la_SOURCES += \
smartcard.c \