summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2011-09-08 02:16:24 +0300
committerAlon Levy <alevy@redhat.com>2011-10-25 09:20:45 +0200
commit80caf07e09efe14c67f89a3c01501a6a39681167 (patch)
tree8ea10bcfc0d206e73cb8ab87148479de999a3f91 /server/Makefile.am
parent691afbbab56cb7b42bafd97b80221b8486d6cc10 (diff)
downloadspice-80caf07e09efe14c67f89a3c01501a6a39681167.tar.gz
spice-80caf07e09efe14c67f89a3c01501a6a39681167.tar.xz
spice-80caf07e09efe14c67f89a3c01501a6a39681167.zip
[0.8 branch] server: add main_dispatcher
add main_dispatcher, a message passing mechanism for sending messages to the main thread. The main thread is the thread that implements SpiceCoreInterface, which is assumed to be a single thread. Similar to the async operation of red_worker, a socket pair is created and used to pass messages. The messages are a fixed size to ease parsing. A single message is defined to pass a channel_event. RHBZ: 746950 FDBZ: 41858 This patch is 0.8 branch only, for the master branch there should be a better approach to share code with red_dispatcher and ready the way for later adding more threads.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index 93ed3120..ebb0d3f2 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -114,6 +114,8 @@ libspice_server_la_SOURCES = \
red_common.h \
red_dispatcher.c \
red_dispatcher.h \
+ main_dispatcher.c \
+ main_dispatcher.h \
red_memslots.c \
red_memslots.h \
red_parse_qxl.c \