summaryrefslogtreecommitdiffstats
path: root/server/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2010-03-09 12:23:49 +0100
committerAlexander Larsson <alexl@redhat.com>2010-03-11 12:13:59 +0100
commit440ac41cf1dc09a4dde43790f9f9d5a83bfb4a45 (patch)
treed0e479bc6f5eb6e100343e684630afa199694119 /server/Makefile.am
parent22b551f97faf4a16dd030a4518cfb6afd151138f (diff)
downloadspice-440ac41cf1dc09a4dde43790f9f9d5a83bfb4a45.tar.gz
spice-440ac41cf1dc09a4dde43790f9f9d5a83bfb4a45.tar.xz
spice-440ac41cf1dc09a4dde43790f9f9d5a83bfb4a45.zip
New memory allocators that exit on OOM and handle multiplication overflow
Every place that does a regular malloc/calloc and aborts on failure should use spice_malloc/spice_mallo0 instead, which is leaner and cleaner. Allocations of dynamically sized arrays can use g_malloc_n or g_new etc which correctly handle multiplication overflow if some of the arguments are not trusted.
Diffstat (limited to 'server/Makefile.am')
-rw-r--r--server/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/server/Makefile.am b/server/Makefile.am
index f91debd1..0b6cb13d 100644
--- a/server/Makefile.am
+++ b/server/Makefile.am
@@ -30,6 +30,7 @@ COMMON_SRCS = \
$(top_srcdir)/common/quic.c \
$(top_srcdir)/common/lz.c \
$(top_srcdir)/common/canvas_utils.c \
+ $(top_srcdir)/common/mem.c \
$(NULL)
lib_LTLIBRARIES = libspice.la