summaryrefslogtreecommitdiffstats
path: root/docs/manual/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2014-01-13 20:01:42 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2014-01-20 12:18:15 +0100
commit7095563153af0e3481605eb5979ca8e6982d95cc (patch)
tree94c8deb74a74571478755ed75c079ba4f1724d10 /docs/manual/Makefile.am
parent2ea58dd7a7ec2952e85814ead55d1694584aa471 (diff)
downloadspice-7095563153af0e3481605eb5979ca8e6982d95cc.tar.gz
spice-7095563153af0e3481605eb5979ca8e6982d95cc.tar.xz
spice-7095563153af0e3481605eb5979ca8e6982d95cc.zip
Add reference manual
This manual documents how to enable/use various SPICE features when creating a VM by running QEMU directly, or when using libvirt, or when using virt-manager. This is based on work by Lubos Kocman
Diffstat (limited to 'docs/manual/Makefile.am')
-rw-r--r--docs/manual/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/docs/manual/Makefile.am b/docs/manual/Makefile.am
new file mode 100644
index 00000000..75cc4f79
--- /dev/null
+++ b/docs/manual/Makefile.am
@@ -0,0 +1,38 @@
+SUFFIXES = .xml .html .txt .1
+
+# apparently, xmlto does not support validation of docbook5 docs
+# that's why it's disabled with --skip-validation
+.xml.html:
+ $(AM_V_GEN)$(XMLTO) --skip-validation -o html xhtml $<
+
+.xml.1:
+ $(AM_V_GEN)$(XMLTO) --skip-validation -o man man $<
+
+.xml.txt:
+ $(AM_V_GEN)$(XMLTO) --skip-validation -o txt txt $<
+
+all: allhtml manpages
+
+XMLMAN =
+XMLDOC = \
+ SpiceUserManual-Basics.xml \
+ SpiceUserManual-Guest.xml \
+ SpiceUserManual-Installation.xml \
+ SpiceUserManual-Introduction.xml \
+ SpiceUserManual-References.xml \
+ SpiceUserManual.xml
+XMLALL = $(XMLMAN) $(XMLDOC)
+SOURCES = $(XMLALL) $(TXTDOC)
+
+allhtml: $(XMLALL:.xml=.html)
+
+manpages: $(XMLMAN:.xml=.1)
+
+# Control what goes in the distribution tarball.
+# We include all of the XML, and also generated HTML pages
+# so people working from the distribution tarball won't need xmlto.
+EXTRA_DIST = $(SOURCES) html
+
+clean-local:
+ rm -fr html $(XMLMAN:.xml=.1)
+