summaryrefslogtreecommitdiffstats
path: root/docs/manual/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2014-03-19 12:34:47 +0100
committerMarc-André Lureau <marcandre.lureau@gmail.com>2014-03-19 17:14:44 +0100
commit2e730453bfe45636b611b86c2c619920f246977f (patch)
tree499adb142e6a40471e12ced7ce1da715585bd63c /docs/manual/Makefile.am
parent25f6745202d204c25df5f9527128ec8fa95dafeb (diff)
downloadspice-2e730453bfe45636b611b86c2c619920f246977f.tar.gz
spice-2e730453bfe45636b611b86c2c619920f246977f.tar.xz
spice-2e730453bfe45636b611b86c2c619920f246977f.zip
Translate docbook -> asciidoc
It's much much easier to read and edit, and the end results looks better as well, see http://elmarco.fedorapeople.org/manual.html
Diffstat (limited to 'docs/manual/Makefile.am')
-rw-r--r--docs/manual/Makefile.am37
1 files changed, 13 insertions, 24 deletions
diff --git a/docs/manual/Makefile.am b/docs/manual/Makefile.am
index e8856a63..f464e7a4 100644
--- a/docs/manual/Makefile.am
+++ b/docs/manual/Makefile.am
@@ -1,30 +1,19 @@
-all: html
-.PHONY: html
+NULL =
+SUFFIXES = .html
+ASCIIDOC_FLAGS = -a icons -a toc
-# apparently, xmlto does not support validation of docbook5 docs
-# that's why it's disabled with --skip-validation
-XMLTO_FLAGS = --skip-validation
-
-XMLDOC = \
- SpiceUserManual-Basics.xml \
- SpiceUserManual-Guest.xml \
- SpiceUserManual-Installation.xml \
- SpiceUserManual-Introduction.xml \
- SpiceUserManual-References.xml \
- SpiceUserManual.xml \
+EXTRA_DIST = \
+ docbook-xsl.css \
+ images/icons/*.png \
+ images/spicec01.png \
+ manual.html \
+ manual.txt \
$(NULL)
-html-stamp: $(XMLDOC)
- $(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) -o html xhtml $(srcdir)/SpiceUserManual.xml
- touch $@
-
-html: html-stamp
+.txt.html:
+ $(AM_V_GEN) $(ASCIIDOC) $(ASCIIDOC_FLAGS) $<
-# Control what goes in the distribution tarball.
-# We include all of the XML, and also generated HTML pages
-# so people working from the distribution tarball won't need xmlto.
-EXTRA_DIST = $(XMLDOC) html html-stamp
+all-local: manual.html
clean-local:
- rm -fr html
- rm -f *-stamp
+ rm manual.html