summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-10-16 17:29:46 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2015-10-23 14:35:14 +0200
commitd88b1fee747cdf420810c919512c0786cbc2a235 (patch)
tree5aef892c51028cc94a2cfe6ffcb0321ad5b4deff /configure.ac
parent90a08ebae83087ac3fd373e2152911433f2ae53c (diff)
downloadspice-d88b1fee747cdf420810c919512c0786cbc2a235.tar.gz
spice-d88b1fee747cdf420810c919512c0786cbc2a235.tar.xz
spice-d88b1fee747cdf420810c919512c0786cbc2a235.zip
build-sys: Adjust to new spice-common spice-deps.m4
This commit also updates the spice-common submodule Christophe Fergeau (7): Add marshaller test case build-sys: Use ${PKG_CONFIG} rather than pkg-config build-sys: Rework SPICE_CHECK_* m4 macros build-sys: Add gio-2.0 to SPICE_CHECK_GLIB2 build-sys: Fix error in SPICE_CHECK_LZ4 description build-sys: Set automake conditional in SPICE_CHECK_SMARTCARD build-sys: Rename SUPPORT_GL to HAVE_GL Javier Celaya (1): Fix linearization of several marshallers with one item Lukas Venhoda (3): ssl-verify: Only check addr length when using IP addr m4: Require glib version >= 2.22 ssl-verify: Changed IPv4 hostname to IPv6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 283bdb86..dfb967b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,14 +72,13 @@ esac
dnl =========================================================================
dnl Check optional features
-SPICE_CHECK_OPENGL([GL])
+SPICE_CHECK_OPENGL
AS_IF([test x"$enable_opengl" != "xno"], [
AS_VAR_APPEND([SPICE_NONPKGCONFIG_LIBS], [" $GL_LIBS"])
])
-SPICE_CHECK_SMARTCARD([SMARTCARD])
-AM_CONDITIONAL(SUPPORT_SMARTCARD, test "x$have_smartcard" = "xyes")
+SPICE_CHECK_SMARTCARD
AC_ARG_ENABLE([automated_tests],
AS_HELP_STRING([--enable-automated-tests], [Enable automated tests using spicy-screenshot (part of spice--gtk)]),,
@@ -87,7 +86,7 @@ AC_ARG_ENABLE([automated_tests],
AS_IF([test x"$enable_automated_tests" != "xno"], [enable_automated_tests="yes"])
AM_CONDITIONAL(SUPPORT_AUTOMATED_TESTS, test "x$enable_automated_tests" != "xno")
-SPICE_CHECK_LZ4([LZ4])
+SPICE_CHECK_LZ4
dnl =========================================================================
dnl Check deps