summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNahum Shalman <nshalman@elys.com>2013-07-18 14:07:13 -0400
committerYonit Halperin <yhalperi@redhat.com>2013-07-22 12:01:59 -0400
commitc07ba1cd4f357c0c6f89e71e3eabf12de5d4ec23 (patch)
treeaac981729a0455271d1c18997e643720fe55f670 /configure.ac
parent7f3f51142caa19acd3f7de1daeced44649ed17c7 (diff)
downloadspice-c07ba1cd4f357c0c6f89e71e3eabf12de5d4ec23.tar.gz
spice-c07ba1cd4f357c0c6f89e71e3eabf12de5d4ec23.tar.xz
spice-c07ba1cd4f357c0c6f89e71e3eabf12de5d4ec23.zip
TIOCOUTQ -> SIOCOUTQ and portability ifdefs
The ioctl on sockets is actually named SIOCOUTQ though its value is identical to TIOCOUTQ which is for terminals. SIOCOUTQ is linux specific so we add a header check and ifdef based on the presence of the header This prevents bogus ioctls on non-Linux platforms
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a549ed93..fa1ba316 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,7 @@ PKG_PROG_PKG_CONFIG
AC_CHECK_HEADERS([sys/time.h])
AC_CHECK_HEADERS([execinfo.h])
+AC_CHECK_HEADERS([linux/sockios.h])
AC_FUNC_ALLOCA
AC_DEFINE([__STDC_FORMAT_MACROS],[],[Force definition of format macros for C++])