summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2015-08-14 11:20:05 +0200
committerFrediano Ziglio <fziglio@redhat.com>2015-08-20 12:30:55 +0100
commit5acc0176380b74546259690f5562a9404f1dec4f (patch)
tree4e5332564fc858f3c5e0187ce5f94cbebea7a0d2 /configure.ac
parentbdeef8b292ab2e3edea8e8ab9683d56d59d29953 (diff)
downloadspice-5acc0176380b74546259690f5562a9404f1dec4f.tar.gz
spice-5acc0176380b74546259690f5562a9404f1dec4f.tar.xz
spice-5acc0176380b74546259690f5562a9404f1dec4f.zip
build-sys: Remove spice-protocol submodule
It's seeing regular releases and is API stable, so we don't need to bundle it with spice-server
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5b4caa4b..5048c418 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,7 +92,7 @@ dnl =========================================================================
dnl Check deps
AC_CONFIG_SUBDIRS([spice-common])
-COMMON_CFLAGS='-I ${top_srcdir}/spice-common/ -I ${top_builddir}/spice-common/ -I ${top_srcdir}/spice-common/spice-protocol/'
+COMMON_CFLAGS='-I ${top_srcdir}/spice-common/ -I ${top_builddir}/spice-common/'
AC_SUBST(COMMON_CFLAGS)
AC_CHECK_LIBM
@@ -109,6 +109,9 @@ AS_IF([test x"$have_smartcard" = "xyes"], [
AS_VAR_APPEND([SPICE_REQUIRES], [" libcacard >= 0.1.2"])
])
+PKG_CHECK_MODULES([SPICE_PROTOCOL], [spice-protocol >= 0.12.10])
+AS_VAR_APPEND([SPICE_REQUIRES], [" spice-protocol >= 0.12.10"])
+
PKG_CHECK_MODULES([GLIB2], [glib-2.0 >= 2.22])
AS_VAR_APPEND([SPICE_REQUIRES], [" glib-2.0 >= 2.22"])