summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@qasl.de>2013-11-03 18:38:55 +0100
committerChristophe Fergeau <cfergeau@redhat.com>2013-11-04 12:02:16 +0100
commit58195c195110f0dbb24d831b5eefb2f094848b26 (patch)
treeee702d6159b391ab8a74e8adb427a963624dac2d /configure.ac
parent8af619009660b24e0b41ad26b30289eea288fcc2 (diff)
downloadspice-58195c195110f0dbb24d831b5eefb2f094848b26.tar.gz
spice-58195c195110f0dbb24d831b5eefb2f094848b26.tar.xz
spice-58195c195110f0dbb24d831b5eefb2f094848b26.zip
Require alsa only with --enable-client
Hey guys, the alsa libraries/header seem to be required only when configured with --enable-client so I wrote a patch to make configure respect it. -- Regards, Christian Ruppert From 53683cc75ba092799f856f710cb45b2aacfb6123 Mon Sep 17 00:00:00 2001 From: Christian Ruppert <idl0r@gentoo.org> Date: Sun, 3 Nov 2013 18:36:26 +0100 Subject: [PATCH] Require alsa only with --enable-client
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 7e81329c..882bf1b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -246,12 +246,6 @@ fi
AC_MSG_RESULT([found])
fi
-if test "$os_linux" = yes; then
- PKG_CHECK_MODULES(ALSA, alsa)
- AC_SUBST(ALSA_CFLAGS)
- AC_SUBST(ALSA_LIBS)
-fi
-
PKG_CHECK_MODULES(SSL, openssl)
AC_SUBST(SSL_CFLAGS)
AC_SUBST(SSL_LIBS)
@@ -280,6 +274,12 @@ AC_SUBST(GL_LIBS)
SPICE_NONPKGCONFIG_LIBS+=" $GL_LIBS"
if test "x$red_target" = "xx11" && test "x$enable_client" = "xyes" ; then
+ if test "$os_linux" = yes; then
+ PKG_CHECK_MODULES(ALSA, alsa)
+ AC_SUBST(ALSA_CFLAGS)
+ AC_SUBST(ALSA_LIBS)
+ fi
+
PKG_CHECK_MODULES(XRANDR, xrandr)
PKG_CHECK_MODULES(XFIXES, xfixes)
PKG_CHECK_MODULES(MISC_X, x11 xext xrender)