summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy White <jwhite@codeweavers.com>2013-11-30 09:14:44 -0600
committerChristophe Fergeau <cfergeau@redhat.com>2014-01-02 12:34:34 +0100
commit4c7c0ef3a70001b1bc9011ef824d3c6fcccd9ca0 (patch)
tree22ff63f9ed6e7bc671244ece6cba72da61851740 /configure.ac
parent4fc9ba5f27dd4c04441d38c893ee962da01baf80 (diff)
downloadspice-4c7c0ef3a70001b1bc9011ef824d3c6fcccd9ca0.tar.gz
spice-4c7c0ef3a70001b1bc9011ef824d3c6fcccd9ca0.tar.xz
spice-4c7c0ef3a70001b1bc9011ef824d3c6fcccd9ca0.zip
Revise the spice client and server to use the new snd_codec functions in spice-common.
This makes celt optional, and paves the way to readily add additional codecs. Signed-off-by: Jeremy White <jwhite@codeweavers.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index db4fd891..c897368a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -230,11 +230,13 @@ AC_SUBST(PIXMAN_CFLAGS)
AC_SUBST(PIXMAN_LIBS)
SPICE_REQUIRES+=" pixman-1 >= 0.17.7"
-PKG_CHECK_MODULES(CELT051, celt051 >= 0.5.1.1)
-AC_SUBST(CELT051_CFLAGS)
-AC_SUBST(CELT051_LIBS)
-AC_SUBST(CELT051_LIBDIR)
-SPICE_REQUIRES+=" celt051 >= 0.5.1.1"
+AC_ARG_ENABLE(celt051,
+ [ --disable-celt051 Disable celt051 audio codec (enabled by default)],,
+ [enable_celt051="yes"])
+
+if test "x$enable_celt051" = "xyes"; then
+ PKG_CHECK_MODULES(CELT051, celt051 >= 0.5.1.1, SPICE_REQUIRES+=" celt051 >= 0.5.1.1")
+fi
if test ! -e client/generated_marshallers.cpp; then
AC_MSG_CHECKING([for pyparsing python module])