summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2014-03-19 12:34:47 +0100
committerMarc-André Lureau <marcandre.lureau@gmail.com>2014-03-19 17:14:44 +0100
commit2e730453bfe45636b611b86c2c619920f246977f (patch)
tree499adb142e6a40471e12ced7ce1da715585bd63c /configure.ac
parent25f6745202d204c25df5f9527128ec8fa95dafeb (diff)
downloadspice-2e730453bfe45636b611b86c2c619920f246977f.tar.gz
spice-2e730453bfe45636b611b86c2c619920f246977f.tar.xz
spice-2e730453bfe45636b611b86c2c619920f246977f.zip
Translate docbook -> asciidoc
It's much much easier to read and edit, and the end results looks better as well, see http://elmarco.fedorapeople.org/manual.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index aaa7ffc1..53d05a22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -422,14 +422,12 @@ AC_ARG_ENABLE([manual],
[],
[enable_manual="auto"])
if test "x$enable_manual" != "xno"; then
- AC_PATH_PROG([XMLTO], [xmlto])
- AS_IF([test -z "$XMLTO" && test "x$enable_manual" = "xyes"],
- [AC_MSG_ERROR([xmlto is missing and build of manual was requested])]
- [have_xmlto = no]
- )
+ AC_PATH_PROG([ASCIIDOC], [asciidoc])
+ AS_IF([test -z "$ASCIIDOC" && test "x$enable_manual" = "xyes"],
+ [AC_MSG_ERROR([asciidoc is missing and build of manual was requested])])
fi
-AS_IF([test -n "$XMLTO"], [have_xmlto=yes], [have_xmlto=no])
-AM_CONDITIONAL([BUILD_MANUAL], [test -n "$XMLTO"])
+AS_IF([test -n "$ASCIIDOC"], [have_asciidoc=yes], [have_asciidoc=no])
+AM_CONDITIONAL([BUILD_MANUAL], [test -n "$ASCIIDOC"])
dnl ===========================================================================
@@ -545,7 +543,7 @@ echo "
Automated tests: ${enable_automated_tests}
- Manual: ${have_xmlto}
+ Manual: ${have_asciidoc}
"
if test $os_win32 == "yes" ; then