summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Levy <alevy@redhat.com>2011-01-17 01:26:39 +0200
committerAlon Levy <alevy@redhat.com>2011-02-07 18:49:29 +0200
commite2d6e8ef4f190273b6fcc848575f37f2c37dc89d (patch)
treea294c96e2f4e6e5cedfef966fccdde5445631858 /configure.ac
parent31db6ef8c2162700605592e8dfece19033a4265c (diff)
downloadspice-e2d6e8ef4f190273b6fcc848575f37f2c37dc89d.tar.gz
spice-e2d6e8ef4f190273b6fcc848575f37f2c37dc89d.tar.xz
spice-e2d6e8ef4f190273b6fcc848575f37f2c37dc89d.zip
configure.ac: use AC_LANG_SOURCE in AC_COMPILE_IFELSE, silence remaining warnings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9b5385d6..9159b4ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -309,7 +309,7 @@ AC_DEFUN([SPICE_CC_TRY_FLAG], [
spice_save_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $1"
- AC_COMPILE_IFELSE([ ], [spice_cc_flag=yes], [spice_cc_flag=no])
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([ ])], [spice_cc_flag=yes], [spice_cc_flag=no])
CFLAGS="$spice_save_CFLAGS"
if test "x$spice_cc_flag" = "xyes"; then
@@ -430,13 +430,13 @@ dnl -fvisibility stuff
have_gcc4=no
AC_MSG_CHECKING(for -fvisibility)
-AC_COMPILE_IFELSE([
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#if defined(__GNUC__) && (__GNUC__ >= 4)
#else
error Need GCC 4.0 for visibility
#endif
int main () { return 0; }
-], have_gcc4=yes)
+])], have_gcc4=yes)
if test "x$have_gcc4" = "xyes" -a ! "$os_win32" = "yes" ; then
VISIBILITY_HIDDEN_CFLAGS="-fvisibility=hidden"